AKAI Professional

Akai Pro MPC Software 2.0 - Using List Edit Mode


Rate this article

Article updated 06-21-2018

The MPC workflow tends to lend itself to various methods of getting from point A to point B whether you are creating and editing audio or editing your sequences.  The MPC List Editor provides a means of visualizing the various elements of your projects in an organized and linear way. This article will cover what the List Editor is, why you might want to use it over Grid Edit, and will provide an example of editing a project through the List Edit Mode menu.

 

Contents

 

What is List Edit Mode and why is it useful?

List Edit Mode (an interchangeable term for List Editor) provides an alternative to using Grid Editor to edit MIDI sequences and automation. Where Grid Editor provides a visual representation of the MIDI events in a sequence as bars of MIDI notes, List Editor is text-based.

As its name suggests, List Edit shows the events of a sequence in a list. The types of event categories that are included in the List Edit menu are Time, Event Type, Pad/Note, Length, Velocity, Mod Type, and Value. Events that are added to a sequence will be sorted into one of these categories. Events can be sorted in List Edit if you only want to see a specific type of data. Sorting options include: All events, Notes, Aftertouch, Track Automation, Program Automation, Pitch Bend, Control Change, Program Change, Channel Pressure, Solo/Mute, and Other miscellaneous events like pad and keygroup parameters. 

Events can be added, deleted, and duplicated within the List Edit Mode menu.

In lieu of the playhead in Grid Editor, a red arrow at the left of the List Edit menu will indicate the current location in the sequence that is selected or will scroll through the events when the sequence is playing.

Additional information about List Edit Mode can be found in the MPC hardware and software user guides.

 

How is List Edit Mode used on the MPC hardware and MPC Software?

List Edit Mode on MPC X and MPC Live in Standalone Mode
To access List Edit Mode, press Menu and select List Edit. We will work off the image below for reference:

List Edit - Hardware

The upper portion of the List Edit menu shows the Track that is currently selected, the sequence location, Timing Correct menu, List Edit parameter sorting (View), automation, settings, etc.

The middle portion of the List Edit menu shows the events of which the sequence is made up. Values that are associated with events can be selected and edited with the Data Dial, the + and - buttons, or the numeric keypad on the MPC X. This portion of List Edit can be sorted so that only specific events are shown with the View field.

The lower portion of the List Edit menu provides options to Insert events, Delete events, Play note events, and Nudge events in the sequence.

Selecting Insert will open a menu in which the location of the event, the type of event, and other pertinent details for the event can be chosen.

Selecting Delete will remove the selected event(s) from the sequence. Multiple events can be selected at once by holding Shift and selecting events with the Data Dial or the + and - buttons. Multiple specific events can be selected individually by holding Shift and choosing the events with the touch display.

Selecting Play will play a MIDI note event. The Play function is only used for MIDI note events.

Selecting Nudge enables the selected event(s) to be moved in the sequence with the Data Dial or the + and - buttons.

Note: The red arrow at the left of the List Edit menu (at #6 in the image above) shows the current location of the sequence whether the sequence is playing or stopped.

 

List Edit Mode in MPC Software (MPC X and MPC Live in Controller Mode and MPC Touch)
To access List Edit Mode, select List at the upper left corner of the sequencer. We will work off the image below for reference:

List Edit - Software

In the image above, the events in a sequence can be seen in the order in which they occur in the sequence. Event values can be edited with the value bars adjacent to the event itself. Double-click an event to open a small menu with which multiple parameters can be edited at once. Click a note event to play that note.

Events can be added to a sequence from List Edit with the plus (+) icon and duplicated with the two-pages-and-plus (+) icon at the lower right corner. Events can be sorted by selecting a specific type in the View field at the lower right corner.

Any changes that are made to a sequence (if MIDI note events are added or removed, if automation data is added or removed, etc) will be reflected in both the Grid and List Edit menus; both of these menus show the same information but in different visual ways.

 

An example of using List Edit Mode

List Edit Mode can affect many different elements of a sequence and as a result, it has a multitude of available functions. As an example, we will add an event to a sequence, specifically a Program Change.

The image below shows the MIDI sequence for a bassline.

Program Changes - Example bassline

Let's add a Program Change to the sequence at Bar 4, Beat 4, Tick 0 (where the yellow arrow is pointing) so the timbre of our bass sounds differently at the end of the sequence and then changes back to the original sound at the beginning of the sequence. For this example, we are using AIR Music Tech's Loom hosted within a Setlist in VIP. Setlists in VIP respond to Program Changes by changing the current patch or Multi slot, so by sending a Program Change from a sequence in MPC, the plugin patches within the Setlist can be automatically changed simply by playing the sequence.

Note: This is only an example of how a Program Change can be sent to a plugin. Data such as Program Changes can be sent from a sequence to any plugin that will accept Program Change messages. In the instance of a MIDI track in MPC, Program Changes can be used in sequences to change programs on external MIDI sound modules.

First, let's open List Edit in the MPC Software by clicking List at the upper left corner of the sequencer. The MIDI notes in the sequence will already be populated in the list. Before we add the Program Change mentioned above, we will add a separate Program Change for the original patch we've chosen to make it so that when the sequence completes and loops, the patch changes back to the original patch we used. Select the plus (+) icon at the lower right corner of the software, select Track, and select Program Change like in the image below:

Program Change - Program Change 1

The added Program Change can be seen on the first line in the image above. The value for the Program Change can be edited under the Value parameter. In this example, we have selected a value of 1 because we will be triggering the first slot in VIP's Setlist - configure your own values specifically for the plugin or MIDI sound module you are using.

Now that our first Program Change is in place to revert the plugin patch to the original patch we used, let's add the other program change at Bar 4, Beat 4, Tick 0. We used the software to add the first one - this time, let's use the MPC hardware in Controller mode and refer to the image below:

Program Change - Program Change 2

On your MPC, press the Menu button, then select List Edit. At the bottom of the List Edit menu, select Insert. Use the Insert menu to select the desired Location of the event. In this example, we are adding the Program Change to Bar 4, Beat 4, Tick 0. A Program Change is considered Track Automation so we will select that in the Type field. Next, we will select Program Change in the Parameter field.

Note: Although these are the parameters we are using for the example, you can add many different types of events to a sequence with this same process. When you have selected the desired location, event type, and event parameter, choose Do It and the event will be added to the sequence.

Back in the List Edit menu, change the Value of this Program Change to 2 in order to select the second slot in VIP's Setlist.

Now that the events have been added to the sequence, we can easily reference them and if necessary, edit them by sorting List Editor by Program Change. Refer to the images below:

Program Change - Sort Software

Use the View field to sort by a specific parameter in the MPC Software as seen in the image above.

Program Change - Sort Hardware

Use the View field to sort by a specific parameter with the MPC hardware in Controller Mode as seen in the image above.

The automation we have added to the sequence can also be seen in the automation lane under the sequencer in Grid Edit Mode like in the image below:

Program Change - Grid

Finally, we can reference the Setlist being used in VIP to see the plugin patches change. These slots in the VIP Setlist will change in real time as the sequence plays over the Program Changes we've added. When the sequence reaches Bar 4, Beat 4, Tick 0, Thumper Bass will be selected and played. When the sequence loops and passes over the first Program Change, Death Bass will be selected and played until the sequencer reaches the next Program Change.

Program Change - VIP Setlist

 

Further Technical Support

Whether you are a customer or dealer, if you already own an Akai Professional product, or if you just have pre-sales questions, the Akai Professional technical support team is available to help! Visit the link below to connect with any of the following support options: phone support, email support.