AKAI Professional

Akai Pro MPC X and MPC Live - Complete Setup And Routing in Logic Pro X


Rate this article

Article updated 11-14-2017

The MPC X and MPC LIVE combined with the included MPC software create a powerful beat-making machine.  Both the X and Live bring back the legendary stand alone workflow that put Akai on the map. Using the MPC software as a plugin adds even more features and options to connect and interact with your favorite DAW.  This guide walks you through everything you need to know about using the Akai Pro MPC X and LIVE as a plugin inside Logic Pro X.

 

Contents

  1. Authorizing MPC
  2. Scanning for the Plugin
  3. Audio / MIDI Setup in Logic  
  4. Loading the Plugin and Resizing the Window
  5. Mapping the Transport Controls
  6. Using the Sample Record Feature
  7. Using Multi-Output Plugin Options
  8. Exporting All Tracks as Audio Files
  9. Further Technical Support

 

Authorizing MPC

You will need to unlock the hardware by authorizing the MPC software before you begin. Before using the plugin, first launch the standalone version of the MPC application to authorize it. For a complete walkthrough on authorizing the software, check out the following article:

Scanning for the Plugin: 

Logic X will automatically scan for new AU plugins when it opens but if it doesn’t, or a plugin scan fails, you can manually scan for it by selecting Preferences > Audio Units Manager.

If you need to manually find the plugin, the file path is: Macintosh HD:/Library/Audio/Plug-Ins/Components/ (AU)

On the next page select the MPC plugin to scan.

 

Audio / MIDI Setup in Logic

These steps will assign the MPC X or Live as the audio input/output device in Logic Pro X. 

  1. Put the MPCX or LIVE into Controller mode by pressing the Menu button on the MPC. Enter Controller Mode by selecting the icon that looks like a computer chip with the MPC logo



  2. A message will appear on the MPC asking if you want to enter controller mode. Select Controller Mode at the bottom of the display. Until the MPC software is started, the MPC will display a red screen that reads 'Looking for Computer' and a button that allows you to return to Standalone mode. You can leave this for now until we open MPC. 

  3. In Logic, select Logic Pro X at the top of the screen and then choose Preferences > Audio...

    Logic Audio 1

  4. Select the MPCX or LIVE as audio input, output or both. 

 

 

Loading the Plugin and Resizing the Window

  1. In Logic, press Option+Command+N on your keyboard, or select Track > New to open the New Tracks.

  2. In the window that opens, select Software Instrument, and then click the Create. A new software instrument track will be created.



  3. Above the channel volume slider, click and hold on the blank rectangle titled input to select a plugin to assign to the track.  In the menu that opens, select AU Instruments > Akai Professional > MPC, and choose either the Stereo or the Multi-Output (16xStereo) version of the plugin.

  4. The MPC plugin will launch.  By default, the plugin window will be compact.  You can increase the size of the plugin by clicking and dragging the arrow in the lower-right corner of the window.

 

Mapping the Transport Controls

  1. In the MPC plugin, click on the Options Menu icon.



  2. In the menu that opens, select Edit > Preferences.



  3. On the left of the window that opens, select the Hardware then set the Record/OverDub setting to Host DAW.



    What is this setting for?

    This setting determines where the record command is sent: MPC or the host DAW. Selecting Host DAW for this setting allows the Record button on the MPC hardware to control the Record button out in Logic as opposed to the controlling the Record button inside the MPC plugin.  This is required while you map the transport controls

    After you've mapped the transport controls, feel free to set the Record/Overdub setting back to MPC Plugin if you want to enable record in the MPC plugin. Set the Record/Overdub setting back to Host DAW any time you want to enable record in Logic instead of into the tracks in MPC plugin.


  4. Out in Logic, select Logic Pro > Preferences > Key Commands or press Option+K on your keyboard to open the Key Commands window.

  5. In the window that opens, you'll map the following items in the Global Commands list to the transport buttons on the MPC hardware:
    • Record
    • Stop
    • Play

  6. First, select Record in the Global Commands list,
  7. Click the Learn New Assignment button in the lower-right of the window.



    Logic will now listen for the next MIDI message from any attached controllers.
  1. Press the Record button on the MPC hardware. The Record button on the MPC will be mapped to the Record function in Logic Pro. 

    Note: 
    when you are mapping these controls, the Logic software will react.  It will Record, Stop, Play etc when you press Record, Stop, Play Etc.  Just let this happen. Don't be alarmed, try to stop it, or make any extra clicks until you are done mapping.  Otherwise, you'll accidentally map extra controls incorrectly.
  1. After you've mapped the Record button (Logic will probably be recording now...just let it go), select the Stop function in the Global Commands 
     
  2. Click the Learn New Assignment button in the lower-right of the window. 

  3. Press the Stop button on the MPC hardware. You've now mapped the Stop.

  4. Select the Play function in the Global Commands.

  5. Click the Learn New Assignment button in the lower-right of the window.

  6. Press the Play button on the MPC hardware. You've now mapped the Play.

  7. Now that you've mapped your transport functions, it is a good idea to save a Logic template for yourself so you don't have to remap these controls in the future. Select File > Save as Template to save your current project as a template to save you time in the future. Of course, you can add other things to the templates you save, including your favorite track setups, favorite effects plugins, audio routing etc, until you've created the ultimate template for the way you work.


Using the Sample Record Feature

  1. Connect an audio source (microphone, turntable, synth, etc.) to a physical input on the MPC hardware.

  2. Press the Menu Button on your MPC Live or X and select Sample Record to enter the Sample Record Mode.

  3. In the upper-right of the MPC Plugin window in Logic Pro, select a Side Chain input that matches the physical input on the MPC hardware where the audio source is connected. 



  4. On the screen of the MPC hardware, set Monitor to ON.

  5. You're now ready to sample! Press Arm then Record on the MPC display to begin recording a sample.

 

Using Multi-Output Plugin Options

If you selected the Multi-Output (8xStereo) version when launching the plugin, you'll have additional output options.

  1. Select the Track Mixer tab at the top of the plugin window.

  2. Above the channel fader and Pan knob of each track is an output selection pull-down menu. You can choose from among different available output options for each of your tracks.  Tracks which are assigned to Out 3,4Out 5,6Out 7,8Out 9,10Out 11,12Out 13,14, and Out 15, 16 will be routed to auxiliary tracks out in Logic Pro's mixer.



  3. Out in Logic, open the Mixer by selecting Window > Mixer, or by pressing Command+2 on your keyboard.

  4. On the MPC's channel strip click the button below the M and buttons to reveal the additional output auxiliary channel strips.



  5. Any tracks in your MPC Track Mixer that you have routed to different outputs will be reflected in the channel strips here in Logic's mixer.

 

Exporting All Tracks as Audio Files

  1. To export these discrete outputs to separate audio files, you'll need to have some content in Logic's arrange window.  Select Window > Arrange or press Command + 1 to return to the Arrange window.

    If you've been following along with this guide exactly, you may have only the one MPC track showing in your Arrange window.  It also probably has no MIDI showing in the timeline in the Arrange window (because any MIDI you've recorded so far is inside the MPC plugin). If all of the MIDI and audio in your project is occurring inside the MPC plugin, you'll need to add something to the timeline in the Logic Arrange window to proceed with the audio export.

  2. In the empty timeline to the right of your MPC track in the arrange window, right+click (or Control+click) in the blank space, and select Create Empty MIDI Region from the pull-down menu.



  3. An empty MIDI region will be created in the timeline.  This lets Logic know your project is not totally empty, so you won't get a Nothing to bounce error when we try to export.

  4. Select File > Export > All Tracks as Audio Files. 

  5. In the window that opens, select a Save Format and Bit Depth.  Set Multi-Output Software Instruments to One File per Channel Strip.

  6. Click Save and your separate MPC outputs will be exported to discrete audio files.

 

 

Further Technical Support

Whether you are a customer or dealer, if you already own an Akai Pro product, or if you just have pre-sales questions, the Akai Pro technical support team is available to help!

Visit the link below to connect with any of the following support options: online community support, phone support, email support: