AKAI Professional

MPC X, MPC Live, and MPC Software - Using MIDI Learn in the MPC Software and MPC Standalone Mode


Rate this article

Article updated 05-18-2018

MPC 2.xAs of MPC Software and firmware version 2.2, users can now take advantage of external MIDI controllers to control the software and hardware. MPC's MIDI Learn function allows for unprecedented control and flexibility for controlling parameters in MPC projects. Whether you are assigning controls in the MPC Software or directly on the standalone hardware, parameter assignments will translate and function the same way across both applications for an enhanced and integrated experience. 

 

Contents

 

Using MIDI Learn in the MPC Software

The MIDI Learn function can be used to assign areas of the MPC Software to external MIDI controllers you've connected to your computer. Before assigning controls to parameters in the software, be sure to select your MIDI controller as an Active MIDI Input in the MPC Software's Preferences > MIDI menu. 

To display the MIDI Learn browser, do one of the following:

  • Click the Menu icon (three lines), select View > Browser, and then click MIDI Learn Browser
  • In the lower right corner, click the MIDI controller icon.
  • Windows shortcut key command: Shift + Ctrl + L
  • Mac shortcut key command: Shift + Command + L

To select a MIDI Learn mode, choose either Global or Project at the top of the MIDI Learn browser.

Using Global MIDI assignments is helpful if you intend on using specific MIDI controllers across multiple projects.

Project MIDI assignments are saved within a project file and can be unique to each individual project.

 

Each parameter assignment has the following settings:

  • Target: This is the assigned command or parameter. The list of targets in the Global tab is comprehensive and will be used for all projects in which that MIDI controller is used. The list of targets in the Project tab must be added and selected per project.
  • Type: This is the type of message that the controller is sending. The available message types are: Toggle Button, Momentary Button, Fixed Button, Note, Abs CC, Rel CC Offset, and Rel CC 2’s Complement. The type is automatically detected based on the input of the parameter itself but you can use this field to assign the type manually if the software does not detect it properly.
  • Ch: This is the MIDI channel the control is using.
  • Data: This is the MIDI note number or CC number that the control is sending to the software.
  • Flip: Click this box to select or deselect it. When selected, the control’s polarity will be reversed (e.g., a button’s off state will become its on state and vice versa).

 

Global MIDI Learning in the MPC Software

Use the Global MIDI Learn feature to assign your MIDI controller to pads, Q-Link knobs, transport controls, or other assignable parameters in the MPC software.

To assign a global parameter to a hardware controller:

  1. Click Learn at the top of the MIDI Learn browser so its icon turns yellow. (The Enable button will also activate and turn light gray if it is not already activated.)
  2. Click a parameter that has a yellow overlay to select it. Alternatively, click it in the list in the MIDI Learn Browser.
  3. Move or press the desired control on your MIDI controller.
  4. The controller's MIDI CC value will be shown on the assigned parameter when it is mapped.
  5.  

To assign more controls, repeat steps 2-3 above.

You can stop assigning controls by clicking Learn again so it turns gray.

To clear an assignment, right-click or press and hold Ctrl (Windows) or Control (macOS) and click the assignment in the MIDI Learn browser. Click Clear MIDI Mapping to clear the assignment, press Esc, or click anywhere else to cancel. To select an assignment, click Learn so it turns yellow, and then press and hold Shift while moving the control on your MIDI controller.

Each collection of these assignments is called a MIDI map, which you can export as a file (.xmm) and import into other MPC projects.

You can disable, re-enable, or switch between different MIDI maps while working with your project with the drop-down menu adjacent to the Learn and Enable button. 

To select a MIDI map, click the drop-down menu next to the Enable button. Select Factory to view the available preset MIDI maps, or select User to view MIDI maps you have created. To enable or disable a MIDI map, toggle the Enable button at the top of the MIDI Learn browser. The button is light gray when activated and dark gray when deactivated.

To show only mappings for specific controls or commands, click the View menu above the list of assignments, and then click a type of control or command.

To show only mappings for the selected control type, click the three-lines icon next to the controller menu, and then select List Follows Control so a check mark appears next to it.

To create a new MIDI map, click the three-lines icon next to the controller menu, and then click New MIDI Map.

To create a duplicate of the currently selected MIDI map, click the three-lines icon next to the controller menu, and then click Duplicate. An identical MIDI map will be created and appended with Copy.

To clear all assignments from the current MIDI map, click the three-lines icon next to the controller menu, and then click Clear. In the window that appears, click OK to continue and clear the assignments, or click Cancel to close the window and keep them. (You can do this with MIDI maps from the list of User maps only, not the Factory list.)

To delete the current MIDI map, click the three-lines icon next to the controller menu, and then click Delete. In the window that appears, click OK to continue and delete the MIDI map, or click Cancel to close the window and keep it. (You can do this with MIDI maps from the list of User maps only, not the Factory list.)

To export the current MIDI map, click the three-lines icon next to the controller menu, and then click Export. Use the Export MIDI Mapping window that appears to browse locations on your computer and store the .xmm map file.

To import a MIDI map, click the three-lines icon next to the controller menu, and then click Import. Use the Import MIDI Mapping window that appears to browse locations on your computer and load a .xmm file. 

To refresh the list of MIDI maps, click the three-lines icon next to the controller menu, and then click Refresh. Do this if you have manually placed a MIDI map file in the MIDI Learn folder (in the MPC application folder) and need it to appear in the list.

 

Project MIDI Learning in the MPC Software

Use the Project MIDI Learn feature to assign your MIDI controller to specific parameters in your MPC project. Assignments you create are saved within a project file and are unique to each individual project. Because these MIDI assignments are saved within a project, you can use them while working with a project on both the desktop version of the MPC software or on your MPC hardware in Standalone Mode.

To add a new assignment, select the plus (+) icon to the right of the Learn and Enable buttons. You can press and hold Alt (Windows) or Option (macOS) while moving or pressing multiple controllers to assign them simultaneously. For example, to quickly add four knobs, hold the modifier key (Alt or Option) and turn each knob until they appear in the menu.

Assign parameters with the Target drop-down menu. The available selections in the Target menu are:

  • MIDI Track
  • Audio Track
  • Program
  • Return
  • Submix (not available for MPC Standalone projects)
  • Master

Each of the selections above will contain their own assignable parameters and can be manually assigned to controllers. For example, in order to map a MIDI controller with eight faders to control the volume level of eight audio tracks, do the following:

  • Add eight audio tracks to a project.
  • Open the MIDI Learn menu.
  • Select the Project tab.
  • Add eight parameters in the MIDI Learn menu by selecting the plus (+) icon or holding Alt (Windows) or Option (macOS) and moving each of the controller's faders until all eight have been added. If the plus (+) icon is used, the controller will need to be learned by enabling the Learn button and moving the fader. If multiple controllers are added by holding Alt/Option, the MIDI CC values for those controllers will be automatically added to the assignment.
  • Select the first Target drop-down menu and choose Audio Track > Audio 001 for the first fader.
  • In the second Target drop-down menu, select Mixer > Volume.

Repeat this process for the remainder of the audio tracks (Audio 002, Audio 003, etc.) and faders.

To assign a project parameter to a hardware control with the Learn function:

  1. Click Learn at the top of the MIDI Learn browser so it turns yellow. (The Enable button will also activate and turn light gray if it is not already activated.)
  2. Click the plus (+) icon in the upper-right corner of the browser to create a blank assignment (its Target menus will be set to None and Off). Alternatively, click an assignment that is already in the list if you want to change it.
  3. Click a project-specific parameter (e.g., a mixer setting or program parameter) to select it. The two Target menus will indicate the parameter you selected. Alternatively, click the first Target menu to select a MIDI or audio track, program, return, submix, or master output (for drum programs and clip programs, you can select the entire program or a single pad within it). After that, click the second Target menu to select the parameter.
  4. Move or press the desired control on your MIDI controller.

To assign more controls, repeat steps 2-4.

To stop assigning controls, click Learn again so it turns gray.

To clear an assignment, right-click or press and hold Ctrl (Windows) or Cmd (macOS) and click the assignment in the MIDI Learn browser. Click Clear MIDI Mapping to clear the assignment, or press Esc or click anywhere else to cancel.

To delete an assignment (the entire slot), right-click or press and hold Ctrl (Windows) or Control (macOS) and click the assignment in the MIDI Learn browser. Click Delete Assignment to delete the assignment, or press Esc or click anywhere else to cancel.

To clear all assignments, click the three-lines icon next to the controller menu, and then click Clear All Assignments. In the window that appears, click OK to continue and delete the assignments, or click Cancel to close the window and keep them.

 

Using MIDI Learn on the MPC X or MPC Live hardware in Standalone Mode

MIDI Learn function on the MPC X and MPC Live hardware is part of MIDI Control Mode. To display the MIDI Learn window, press Menu, tap MIDI Control to enter MIDI Control Mode, and then tap the MIDI Learn tab.

Each assignment has the following settings:

Source: This is the name or number of the track, program, return, or master output.

Target: This is the name of the assigned command or parameter.

Type: This is the type of message. This is automatically detected based on the Source and Target fields, though you can use this field to assign it manually if it does not detect it properly. Available selections include:

  • Toggle Button: When the control is a button, pressing it will activate or deactivate its command or parameter. It will remain in that state until you press it again.
  • Momentary Button: When the control is a button, pressing and holding it down will activate its command or parameter. Releasing the button will deactivate it. 
  • Fixed Button: When the control is a button, pressing it will send its command. 
  • Note: When the control is a button, pressing it will send the MIDI note (determined by the Data field).
  • Abs CC: When the control is a knob, turning it will send its CC message (determined by the Data field) according to the precise physical position of the knob. (When you start turning it, the value may jump from its current value to the one corresponding to the knob’s position.) This is for use with knobs that have a maximum and minimum position.
  • Rel CC Offset: When the control is a knob, turning it will send the CC message (determined by the Data field), starting from the current value. This is for use with 360 degree knobs that are controlling parameters with a maximum and minimum position.
  • Rel CC 2’s Complement: When the control is a knob, turning it will send the CC message (determined by the Data field), starting from the current value. This is for use with 360 degree knobs controlling bipolar parameters where there is a center (12 o'clock) position (such as panning).

Ch: This is the MIDI channel the control is using.

Data: This is the MIDI note number or CC number that the control is sending.

Flip: Tap this box to select or deselect it. When selected, the control’s polarity will be reversed (e.g., a button’s off state will become its on state and vice versa).

To assign a parameter to a hardware control:

1. Tap Learn in the upper left corner so it turns yellow. (The Enable Mapping button will also activate if it is not already on.)

2. Tap the plus (+) icon in the lower-left corner to create a blank assignment (its Target menus will be set to None and Off). Alternatively, tap an assignment that is already in the list if you want to change it. 

3. Move or press the desired control on your MIDI controller. The Type, Ch, and Data fields will be automatically assigned. 

4. Use the Source field to select a MIDI or audio track, program, return, or master output (for drum programs and clip programs, you can select the entire program or a single pad within it). The Target menu will indicate the source you selected.

5. Use the Target menu to select the parameter. Your selection will be shown under Target in the list, as well.

The control on your MIDI controller will now control the Target parameter.

To assign more controls, repeat Steps 2-5.

To stop assigning controls, tap Learn again so it turns off.

To clear an assignment, follow the steps above to reassign its Source field to None and assign its Target field to Off.

To delete an assignment (the entire slot), tap it in the list, and then tap the trash can icon in the lower right corner. To delete all assignments, press and hold Shift, and then tap the trash can icon in the lower right corner. In the window that appears, tap Remove All to continue or tap Cancel to not delete any assignments.

 

Further Technical Support

Whether you are a customer or dealer, if you already own an Akai Professional product, or if you just have pre-sales questions, the Akai Professional technical support team is available to help! Visit the link below to connect with any of the following support options: phone support, email support.